Contents

Description...........................................................................................................................................3
Avaya IP PBX Configuration ..................................................................................................................3
Licensing and Physical Hardware.........................................................................................................4
System Tab Configuration ...................................................................................................................5
IP Routing.............................................................................................................................................9
SIP Line Information...........................................................................................................................9
Outbound Call Routing......................................................................................................................16
User Configuration...........................................................................................................................18
Incoming Call Routes..........................................................................................................................18
Save Configuration............................................................................................................................20
1 Description

These Application Notes describe the steps necessary for configuring Session Initiation Protocol (SIP) Trunk Service for an enterprise solution using Avaya IP Office Release 9.0 to interoperate with Nextiva SIP Services (NextOS).

In the sample configuration, the Avaya IP Office solution consists of Avaya IP Office (hereafter referred to as IP Office) 500v2 Release 9.0 and various Avaya endpoints, including Avaya IP Office Video Softphone, Avaya Flare® Experience for Windows, and Avaya desk phones, including SIP, H.323, digital, and analog.

The Nextiva SIP Trunking Service referenced within these Application Notes is designed for business customers. Customers using this service with the Avaya IP Office solution are able to place and receive PSTN calls via a broadband WAN connection using the SIP protocol. This converged network solution is an alternative to traditional PSTN trunks, such as analog and/or ISDN-PRI trunks. This approach generally results in a lower cost for the enterprise.

2 Avaya IP PBX Configuration

Avaya IP Office is configured through the Avaya IP Office Manager PC application. From the Avaya IP Office Manager PC, select Start > Programs > IP Office > Manager to launch the application. A screen that includes the following may be displayed.

Select Open Configuration from System. If the above screen does not appear, the configuration may be alternatively opened by navigating to File > Open Configuration at the top of the Avaya IP Office Manager window. Select the proper Avaya IP Office system from the pop-up window and log in with the appropriate credentials.

The appearance of the IP Office Manager can be customized using the View menu. In the screens presented in this document, the View menu was configured to show the Navigation pane on the left side, omit the Group pane in the center, and show the Details pane on the right side. Since the Group pane has been omitted, its content is shown as submenus in the Navigation pane. These panes (Navigation, Group and Details) will be referenced throughout the Avaya IP Office configuration. All licensing and feature configuration that is not directly related to the interface with the service provider (such as twinning and IP Office Video Softphone support) is assumed to already be in place.

In the sample configuration, the MAC address 00E00706530F was used as the system name.

- All navigation described in the following sections (e.g., License > SIP Trunk Channels) appears as submenus underneath the system name 00E00706530F in the Navigation Pane.
3 Licensing and Physical Hardware

The configuration and features described in these Application Notes require Avaya IP Office to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, contact an authorized Avaya sales representative.

To verify that there is a SIP Trunk Channels License with sufficient capacity; click License in the Navigation pane. Confirm a valid license with sufficient Instances (trunk channels) in the Details pane.

Note that the full License Keys in the screen below is not shown for security purposes.

To view the physical hardware comprising Avaya IP Office, expand the components under the Control Unit in the Navigation pane. In the sample configuration, the Avaya IP Office 500v2 is equipped with analog and digital extension expansion modules, as well as a VCM64 (Voice Compression Module) for supporting VoIP codecs.

- An Avaya IP Office hardware configuration with a VCM component is necessary to support SIP trunking.

To view the details of the component, select the component in the Navigation pane. The following screen shows the details of the IP 500 V2.
4 System Tab Configuration

Configure the necessary system settings. In an Avaya IP Office, the LAN2 tab settings correspond to the Avaya IP Office WAN port (public network side) and the LAN1 tab settings correspond to the LAN port (private network side).

System Information - LAN2 Tab

In the sample configuration, the Avaya IP Office WAN port was used to connect to Nextiva. The LAN2 settings correspond to the WAN port on the Avaya IP Office 500 V2.

To access the LAN2 settings, first navigate to System > <Name>, where <Name> is the system name assigned to the Avaya IP Office.

- In the case of the compliance test, the system name is the MAC address 00E00706530F.

Next, navigate to the LAN2 > LAN Settings tab in the Details Pane.

1. Set the IP Address field to the public IP address assigned to the Avaya IP Office WAN port.
2. Set the IP Mask field to the mask used with the public IP address. All other parameters should be # set to default or according to customer requirements.
3. Click Ok to commit (not shown).
System - LAN 2 - VoIP Tab

On the VoIP tab in the Details Pane, configure the following parameters:

1. Check the **SIP Trunks Enable box** to enable the configuration of SIP trunks.
2. The **RTP Port Number Range** can be customized to a specific range of receive ports for RTP media.

Do not specify Nextiva SIP Ports in this area. SIP Ports are not the same as RTP ports and in this case, 5060-5090 should **NOT** be used.

Based on this setting, Avaya IP Office would request RTP media be sent to a **UDP port** in the configurable range for calls using **LAN2**.

1. Continue to scroll down the page:
2. In the **RTP Keepalives section**, set the **Scope to RTP**. Set the periodic timeout to 30 and the **Initial Keepalives parameter to Enabled**. These settings will cause Avaya IP Office to send a RTP keepalive packet starting at the time of initial connection and every 30 seconds thereafter if no other RTP traffic is present. This facilitates the flow of media in cases where each end of the connection is waiting to see media from the other, as well as helping to keep firewall ports open for the duration of the call.
3. In the **DiffServ Settings section**, Avaya IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) in the IP Header with specific values to support Quality of Services policies for both signaling and media. The **DSCP field** is the value used for media and the **SIG DSCP** is the value used for signaling. The specific values used for the compliance test are shown in the example below and are also the default values.
4. All other parameters should be set to default or according to customer requirements.
5. Click **Ok** to commit (not shown).

System - LAN 2 - Network Topology

![Network Topology Diagram]
On the **Network Topology** tab in the Details Pane, configure the following parameters:

1. Select the **Firewall/NAT Type** from the pull-down menu that matches the network configuration. Since no firewall or network address translation (NAT) device was used between the Avaya IP Office and the Nextiva, the parameter was set to **Open Internet**.

2. Set the **Binding Refresh Time** (seconds) to a desired value, the value of **300 (or every 5 minutes)** was used during the compliance testing. This value is used to determine the frequency that IP Office will send OPTIONS heartbeat to the service provider.

3. Set **Public IP Address** to the IP address of the Avaya IP Office WAN port.

4. In the **Public Port** section, next to the transport protocol **UDP**, select the UDP port on which Avaya IP Office will listen.

5. All other parameters should be set to default or according to customer requirements.

6. Click **Ok** to commit (not shown).

**NOTE:** In the compliance test, the LAN1 interface was used to connect the Avaya IP Office to the enterprise site IP network (private network). The LAN1 interface configuration is not directly relevant to the interface with the Nextiva SIP Trunk Service, and therefore is not described in these Application Notes.

---

**System - Telephony Tab**

To access the System Telephony settings, navigate to the **Telephony > Telephony tab** in the Details Pane.

1. Uncheck the **Inhibit Off-Switch Forward/Transfer box** to allow call forwarding and call transfer to the PSTN. If for security reasons incoming calls should not be allowed to transfer back to the PSTN, then leave this setting checked. All other parameters should be set to default or according to customer requirements.

2. Click **OK** to commit (not shown).
System - Twinning Tab

1. To view or change the System Twinning settings, navigate to the **Twinning tab** in the Details Pane as shown in the following screen.
2. The **Send original Calling party information for Mobile Twinning** box is not checked in the sample configuration, and the Calling party information for Mobile Twinning is left blank.
3. Click **OK** to commit (not shown).

![System Twinning Tab](image)

System - Codecs Tab

In the Codecs tab of the Details Pane, select or enter 101 for RFC2833 Default Payload. This setting is recommended by Nextiva for use with out-band DTMF tone transmissions.

For Codec Selection, select the codecs and codec order of preference on the right, under the Selected column. The example below shows the codecs used for the compliance test. Note that System Default Codec Selection was used under the SIP Line - VoIP Tab in Section 5.4.5, which corresponds to the codec setting shown here. The list must include G.711 ULAW, G.711ALAW and G.729(a) which are the codecs supported by Nextiva. Codecs are listed in preferred codec order (from top to bottom).

![System Codecs Tab](image)
5  IP Routing

Create an IP route to specify the IP address of the gateway or router where the IP Office needs to send the packets in order to route calls to Nextiva’s network.

Navigate to IP Route > 0.0.0.0 in the left Navigation Pane if a default route already exists, otherwise, to create the default route, right-click on IP Route and select New. Create/verify a default route with the following parameters:

1. Set IP Address and IP Mask to 0.0.0.0.
2. Set Gateway IP Address to the IP address of the default router for the public network where Avaya IP Office is connected.
3. Set Destination to LAN2 from the drop-down list.
4. Click the OK to commit (not shown).

6  SIP Line Information

A SIP line is needed to establish the SIP connection between Avaya IP Office and Nextiva SIP Trunk Services. The recommended method for configuring a SIP Line is to use the template associated with these Application Notes. The template is a .xml file that can be used by IP Office Manager to create a SIP Line.

Some items relevant to a specific customer environment are not included in the template or may need to be updated after the SIP Line is created. Examples include the following:

1. IP addresses
2. SIP Trunk Registration Credentials
3. SIP URI entries
4. Setting of the Use Network Topology Info field on the Transport tab

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after the SIP Line is created via the template.

Also, the following SIP Line settings are not supported on Basic Edition:

- SIP Line – Originator number for forwarded and twinning calls
- Transport – Second Explicit DNS Server
- SIP Credentials – Registration Required
To create a SIP Line manually, right-click Line in the Navigation Pane, and select **New > SIP Line**.

**Using SIP Line Templates**

**Step 1**
Copy the template file to the computer where IP Office Manager is installed. Rename the template file to **US_Nextiva_SIPTrunk.xml**. The file name is important in locating the proper template file in Step 5.

**Step 2**
Verify that template options are enabled in IP Office Manager. In IP Office Manager, navigate to **File > Preferences**. In the IP Office Manager Preferences window that appears, select the Visual Preferences tab. Verify that the box is checked next to **Enable Template Options**. Click OK.

**Step 3**
Import the template into IP Office Manager. From IP Office Manager, select **Tools > Import Templates in Manager**. This action will copy the template file into the IP Office template directory and make the template available in the IP Office Manager pull-down menus in Step 5.

- The default template location is **C:\Program Files\Avaya\IP Office\Manager\Templates**.
In the pop-up window that appears (not shown), select the directory where the template file was copied in Step 1. After the import is complete, a final import status pop-up window (not shown) will appear stating success or failure, click OK (not shown) to continue. If preferred, this step may be skipped if the template file is copied directly to the IP Office template directory.

Step 4
To create the SIP Trunk from the template, right-click on the Line in the Navigation Pane, then navigate to New > New SIP Trunk From Template.
Step 5

In the subsequent Template Type Selection pop-up window, select **United States** from the **Country** pull-down menu and select **Nextiva** from the **Service Provider** pull-down menu as shown below. These values correspond to parts of the file name (**US_Nextiva_SIPTrunk.xml**) created in Step 1. Click **Create new SIP Trunk** to finish creating the trunk.

Step 6

Once the SIP Line is created, verify the configuration of the SIP Line by using the information below in the SIP Line Tab.

### SIP Line - SIP Line Tab

On the **SIP Line** tab in the Details Pane, configure or verify the parameters as shown below.

1. Set **ITSP Domain Name** to `pai.voipdnsservers.com`, the domain name for Nextiva (FQDN).
2. Set **Send Caller ID** to **Diversion header**.
3. Verify **REFER Support** is checked (enabled). Set **Incoming and Outgoing** under REFER Support to **Always**.
4. Verify that **In Service** box is checked, the default value. This makes the trunk available to incoming and outgoing calls.
5. Verify that **Check OOS** box is checked, the default value. Avaya IP Office will use the SIP OPTIONS method to periodically check the SIP Line. The time between SIP OPTIONS sent by Avaya IP Office will use the **Binding Refresh Time** for LAN2, as shown in System LAN 2 Tab.
6. Set the **Call Routing Method** to **To Header**.
7. Set the **Originator number for forwarded and twinning calls** to the SIP Username. This setting is required for forwarded and twinned calls to be accepted by Nextiva. SIP Trunk registration credentials information should be provided by Nextiva.
8. All other parameters should be set to default or according to customer requirements.
9. Click **OK** to commit (not shown).
SIP Line - Transport Tab

Select the Transport tab. Set or verify the parameters as shown below.

1. Leave the ITSP Proxy Address blank (IP Office will retrieve the ITSP Proxy Address using public DNS queries).
2. Set Layer 4 Protocol to UDP.
3. Set Use Network Topology Info to LAN2, the network port used by the SIP line to access the far-end and configured in Section System Information LAN 2 Tab.
4. Set the Send Port to 5060.
5. Set Explicit DNS Server(s) to the IP addresses of the primary and secondary public DNS Servers used by the enterprise. This information should be provided by the local ISP. IP Office will use public DNS queries with the ITSP Domain Name provided above, under SIP Line Tab, then verify with Nextiva's public IP address.
6. Default values may be used for all other parameters.
7. Click OK to commit (not shown).

NOTE: Screenshot may depict an incorrect DNS IP Addresses. Please read step 5 listed above for more information.

SIP Line - SIP URI Tab

Two SIP URI entries must be created to match each outgoing number that Avaya IP Office will send on this line and incoming numbers that Avaya IP Office will accept on this line.

To set the SIP URI for outgoing numbers, select the SIP URI tab, then click the Add button and the New Channel area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the Edit button. The entry was created with the parameters shown below:

1. Set Local URI to the SIP Username. This is the user name credentials provided by Nextiva for SIP Trunk registration purposes. This setting was required for user authentication/validation purpose. For user authentication/validation purpose, Nextiva utilizes the content (number) in the “From” header of the INVITE message, instead of the content (number) in the “PAI” header of the INVITE message.
2. Set Contact, Display Name and PAI to Use Internal Data.
3. Set Registration is set to 0: <None>.
4. Set Incoming Group to 0.
5. Set Outgoing Group to 17 (SIP Line number being used).
6. Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
7. Click OK to commit.
To set the SIP URI for incoming numbers, select the SIP URI tab, then click the Add button and the New Channel area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the Edit button. The entry was created with the parameters shown below:

1. Set Local URI, Contact, Display Name and PAI to Use Internal Data.
2. Set Registration to 0: <None>.
3. Set Incoming Group to 17 (SIP Line number being used).
4. Set Outgoing Group to 0.
5. Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
6. Click OK to commit.
7. On the next screen that appears, click OK again to commit.
SIP Line - VoIP Tab

Select the VoIP tab, to set the Voice over Internet Protocol parameters of the SIP line. Set or verify the parameters as shown below.

1. For Codec Selection, select System Default from the pull-down menu to use the default list of codecs. A list of the codecs in their current order of preference will be shown on the right in the Selected column. To use a custom list of codecs instead, select Custom under Codec Selection. If Custom is used, move unwanted codecs from the Selected column to the Unused column. Lastly, move the codecs up or down the list in the Selected column to achieve the desired order of preference. The example below shows the codecs used for the compliance test. Note that System Default Codec Selection was used. The list must include G.711 UALAW, G.711ALAW and G.729(a) which are the codecs supported by Nextiva. Codecs are listed in preferred codec order (from top to bottom).

2. Uncheck the VoIP Silence Suppression box.

3. Uncheck Allow Direct Media Path and Force direct media with phones box. This setting was not tested.

4. Check the Re-invite Supported box.

5. Check the PRACK/100rel Supported box.

6. Set the Fax Transport Support to G.711.

7. Set the DTMF Support field to RFC2833. This directs Avaya IP Office to send DTMF tones using RTP events messages as defined in RFC2833.

8. Default values may be used for all other parameters.

9. Click the OK to commit (not shown).

SIP Line - SIP Credentials Tab

Select the SIP Credentials tab, and then click the Add button to add the SIP Trunk registration credentials. Set the parameters as show below.

1. Set User name to the Nextiva-provided SIP Username; the user name credential provided by Nextiva for SIP Trunk registration (the user name has been masked for security reasons).

2. Set Authentication Name to the Nextiva-provided authentication name; the authentication name credential provided by Nextiva for SIP Trunk registration.

3. Set Password to the Nextiva-provided authentication password; the password credential provided by Nextiva for SIP Trunk registration.

4. Set Expiry (mins) to a value acceptable to the enterprise. This setting defines how often registration with Nextiva is required following any previous registration. For the compliance, test 2 minutes was used.

5. Verify that Registration required is checked.

6. Click the OK to commit.
For outbound call routing, a combination of system short codes and Automatic Route Selection (ARS) entries are used. With ARS, features like time-based routing criteria and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line group is not available. While detailed coverage of ARS is beyond the scope of these Application Notes, and alternate routing was not used in the reference configuration, this section includes some basic screen illustrations of the ARS settings used during the compliance testing.

### Short Codes and Automatic Route Selection

To create a short code to be used for ARS, right-click on Short Code on the Navigation Pane and select **New**. The screen below shows the short code 9N created (note that the semi-colon is not used here). In this case, when the Avaya IP Office user dials 9 plus any number N, instead of being directed to a specific Line Group ID, the call is directed to **Line Group 50: Main**, which is configurable via ARS.

1. In the **Code** field, enter the dial string, which will trigger this short code. In this case, 9N was used (note that the semi-colon is not used here).
2. Set **Feature** to **Dial**. This is the action that the short code will perform.
3. Set **Telephone Number** to **N**. The value **N** represents the number dialed by the user after removing the 9 prefix. This value is passed to ARS.
4. Set the **Line Group ID** to **50: Main** to be directed to Line Group 50: Main, this is configurable via ARS.
5. Click the **OK** to commit (not shown).
The following screen shows the example ARS configuration for the route Main. Note the sequence of X’s used in the Code column of the entries to specify the exact number of digits to be expected, following the access code and the first set of digits on the string. This type of setting results in a much quicker response in the delivery of the call by IP Office.

To create a short code to be used for ARS, select ARS > 50: Main on the Navigation Pane and click Add.

1. In the Code field, enter the dial string, which will trigger this short code. In this case, 1 followed by 10 X’s to represent the exact number of digits.
2. Set Feature to Dial. This is the action that the short code will perform.
3. Set Telephone Number to 1N. The value N represents the additional number of digits dialed by the user after dialing 1 (The 9 will be stripped off).
4. Set the Line Group ID to the Line Group number being used for the SIP Line, in this case Line Group ID 17 was used.
5. Set Locale to United States (US English).
6. Click OK to commit.

NOTE: Repeat the above procedure for additional dial patterns to be used by the enterprise to dial out from IP Office.

The example highlighted below shows that for calls in the North American numbering plan, the user dialed 9, followed by 1 and 10 digits (represented by 10 X’s). The 9 is stripped off, the remaining digits, including the 1, are included in the SIP INVITE message IP Office sends to Nextiva.
8 User Configuration

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP line defined in Section 5.4. To configure these settings, first navigate to User > Name in the Navigation Pane where Name is the name of the user to be modified.

In the example below, the name of the user is Ext3040 H323. Select the SIP tab in the Details Pane (tab not shown).

The values entered for the SIP Name allow matching of the SIP URI for incoming calls without having to enter this number as an explicit SIP URI for the SIP line.

- The SIP Name and Contact are set to one of the DID numbers assigned to the enterprise by Nextiva.
- The SIP Display Name (Alias) parameter can optionally be configured with a descriptive name.

If all calls involving this user and a SIP Line should be considered private, then the Anonymous box may be checked to withhold the user’s information from the network. This can also be accomplished by activating Withhold Number on H.323 Deskphones.

- Click the OK to commit (not shown).

9 Incoming Call Routes

An incoming call route maps inbound DID numbers on a specific line to internal extensions, hunt groups, short codes, etc., within the IP Office system.

In a scenario like the one used for the compliance test, only one incoming route is needed, which allows any incoming number arriving on the SIP trunk to reach any predefined extension in IP Office.

- The routing decision for the call is based on the parameters previously configured for Call Routing Method and SIP URI and the users SIP Name and Contact, already populated with the assigned Nextiva DID numbers. This information is listed in the above sections.
Incoming Call Route - Standard Tab

On the Standard tab of the Details pane, enter the parameters as shown below.

1. Set **Bearer Capacity** to **Any Voice**.
2. Set the **Line Group ID** to the incoming line group of the SIP line defined in the above section(s), in this case Line Group ID 17 was used.
3. Default values can be used for all other fields.
4. Click **OK** to commit (not shown).

![Standard Tab Image]

Incoming Call Route - Destinations Tab

Under the Destinations tab, enter “.” for the Default Value. This setting will allow the call to be routed to any destination with a value on its SIP Name field, entered on the SIP tab of the User, which matches the number present on the user part of the “To” header on the incoming INVITE message received from Nextiva. Click **OK** to commit (not shown).

![Destinations Tab Image]
10 Save Configuration

Navigate to File > Save Configuration in the menu bar at the top of the screen to save the configuration performed in the preceding sections.

The following will appear, with either Merge or Immediate selected, based on the nature of the configuration changes made since the last save.

**Note:** Clicking OK may cause a service disruption.

- Click OK to proceed.